Si al intentar conectar tu web a la aplicación de Modular has visto un aviso de error y la conexión no se ha podido realizar, podría ser por una de las siguientes razones:

  1. Versión de PHP. Modular solo puede conectarse a webs cuyo servidor funciona con una versión de PHP igual o superior a PHP 7.4. Esto es únicamente por razones de seguridad y es que las versiones anteriores han sido deprecadas y están por tanto obsoletas, como se puede ver aquí.
  2. Versión de WordPress. Al igual que en el caso anterior, si tu web funciona con una versión de WordPress anterior a la 5.6 no será posible establecer la conexión. Una vez más, primamos la seguridad.
  3. Asegúrate de tener la última versión del plugin Modular Connector. Podrás descargar la última versión en este link.
  4. Algún plugin es incompatible: Puedes ver la lista de incompatibilidades conocidas en este enlace.
  5. Bloqueo por parte de tu hosting. Algunos proveedores de servidores / hosting bloquean la petición de login automática, por lo que solo será posible conectar la web manualmente. Estamos trabajando para que no lo hagan con la siguiente versión.
  6. Autenticación de doble factor (2FA) para acceder a Wordpress. Si tienes activado esto en tu web tendrás que conectar tu web con Modular de manera manual.
  7. Llamadas externas del servidor. Si tu servidor bloquea las llamadas externas a otras webs no nos permitirá realizar la conexión. En este caso debéis poneros en contacto con vuestro proveedor para permitir la conexiones con nuestra lista de IPs
  8. WP Memory Limit. Si el Memory Limit establecido en tu servidor es menor de 128MB no funcionará. Recomendamos al menos 256MB o, si tienes otros plugins como Elementor o Woocommerce, al menos 512MB.
  9. Conexión SSL. Si tu web no tiene certificado de seguridad pero la has añadido en el primer paso de conectar web como si lo tuviera, puede causar problemas.
  10. Captcha de acceso. Si has instalado algún plugin de seguridad o tienes un captcha de acceso para iniciar sesión en WordPress, nuestro plugin no podrá resolverlo. Podríamos decir que las mates no se le dan bien. En ese caso tendrás que establecer la conexión de manera manual.
  11. Permisos de usuario administrador. El usuario que pongas al conectar una web con Modular debe tener permisos de administrador.
  12. Upload max file size menos de 5MB. Si tienes este ajuste en tu servidor no será posible subir el plugin ni de manera manual ni automática.
  13. Si usas Cloudflare y has activado la opción Bot Fight Mode puede que tengas problemas si tu cuenta de Cloudflare no se ha actualizado a las nuevas reglas de Firewall.

Si ninguna de las anteriores aplica a tu caso y aún así no eres capaz de establecer conexión, ponte en contacto con nosotros a través de hola@modulards.com para que podamos ayudarte a solucionarlo 😉